Welcome to
 Welcome to riocar.org! Friday, August 6th 
Main Menu
· Web Links
· Downloads
· BBS/Forums
· Lens Compare
· Boot Logos
· Button Guide
· Developer Info
· Drive Upgrade
· FAQ
· Geek Guide
· Photo Gallery


  

rio car dot org FAQ (Frequently Asked Questions)



Category: Main -> Known problems and troubleshooting questions
Search the FAQ
·  Why do the visuals disappear every time I put it in the car? 
·  Why is the stereo image of my MP3 messed up? 
·  I get a 'pump' error when I try to upgrade my player firmware. 
·  I get a Windows Installer or MSI error when I install Emplode. 
·  I'm having trouble with my tuner module! 
·  My tuner gets terrible reception, but the extension cable is fine. 
·  My tuner doesn't tune in the correct frequency increments. 
·  When I pause/un-pause, or sleep/wake the player, it starts in a different part of the song. 
·  Why don't fast forward and rewind work properly? 
·  When I pull the power, sometimes it plays a different song when I start it again. 

·  I can't perform an upgrade, install a logo, or install a kernel when the player is in the docking sled.
 (Entry last updated on April 15th, 2003)

When the player is running on "sled power", i.e., it's getting it juice from the docking connector instead of the home AC-adapter connector, the serial port behaves differently in two important ways:

  • The speed of the serial port is reduced to 4800bps in order to be compatible with other in-car serial devices. This can be changed by adding the following entry to the player's config.ini file:
    [serial]
    car_rate=115200
  • The player doesn't wait on the serial port for the command to write to flash memory. So upgrades, flash writes, etc., do not work. This happens in the protected boot firmware, the hard-coded routine that runs the instant the player is powered on. So even a custom kernel which forces the player into AC mode can't change this behavior; the upgrade prompt happens before the kernel is loaded.
Most of the time, you should be upgrading the player simply by bringing it into the house and plugging it into your PC as it was intended. However some people have done interesting things with docking sleds indoors, so there can be situations where you need to do upgrades through the docking sled.

You can work around this problem by faking the player into thinking it's on AC-adapter power. One way to do this is to plug an "unwired" plug of the correct dimensions into the home power jack. If you're careful, you can also trigger the jack's sensing switch with a matchstick or similar non-conductive object. Although I wouldn't recommend it because you might damage the switch mechanism if you're not careful, and it's a pain to replace it.

It's also possible to design an indoor dock which uses the AC adapter jack for power instead of the docking connnector.

Another thing to remember is that the serial port on the docking sled has some rather funky wiring. For starters, the RX and TX pins (pins 2 and 3) are already "swapped", so you can't use the supplied null-modem cable to connect a PC to the docking sled's serial connector, your cable must have the data pins wired as straight-through. Next, some sleds were accidentally wired without a ground connection on pin 5 and you will need to come up with a makeshift solution, such as grounding your serial cable to the docking sled. Finally, some of the other pins are connected to special features such as the amp remote, the headlight sense, and the mute line. These might confuse a PC serial port. So if you need to hook your PC up to the docking sled, the best solution is probably making a custom cable that uses only pins 2, 3, and 5 (RX/TX and Ground), which are the only pins needed for PC-to-player serial communication.


·  Why did my player suddenly start freezing at the boot-up logo screen? 
·  Why isn't the headlight-sense dimmer working properly? 
·  Why does my player think it's at home when it's in the car? 
·  Why doesn't my player go into standby mode when I turn off the ignition? 
·  Why is there a 'thump' from my amplifiers when I turn off the ignition? 
·  Why doesn't my Rio Car work in my Mark 2 docking sled? 
·  Why is my docking connector loose? 
·  Why is my Mark 1 getting harder and harder to pull out of the sled? 
·  Why is my Mark 2 hard to pull out of the sled? 
·  Why is my warranty seal already broken? 
·  I get a 'hardware revision check failed' message when I try to upgrade! 
·  Why did ethernet and/or USB quit working after I upgraded the software? 
·  My tuner quit working after an upgrade! 
·  Why is the song count different when I shuffle? 
·  Why can't I figure out how to do searches on the player? 
·  I selected the correct title in a search, and pressed OK, but the song did not play. Why? 
·  Why does Emplode keep getting my tags wrong? 
·  Why can't I read the display in the daylight? 
·  Why am I having problems with my car alarm or my keyless entry system? 
·  My rotary knob is slipping on its shaft! 
·  What do the synchronization errors mean? 
·  The clock on my Mark 1 player does not work. 
·  The clock on my Mark 2 player does not work. 
·  The Mark (cancel) key on the Rio remote doesn't work all the time. 
·  Why is the Shuffle menu backwards? 
·  Why does my player say 'Waiting...' on the screen? 
·  Why does my player rattle when I shake it? 
·  I don't like seeing the circuitry when the sun shines on the player. 
·  I have database errors and all of my playlists disappeared! 
·  Why does Emplode say I have less disk space than I think I should have? 
·  Why does my player sound terribly distorted when I plug it into my home stereo? 
·  My remote control quit working! 
·  I have a Kenwood head unit, and its remote is controlling both players. 
·  Why doesn't Emplode work via USB on Windows? 
·  Why doesn't emplode work via ethernet on Windows XP? 
·  Emplode freezes up on 'Checking Disk Integrity'. 
·  I got an error message about 'e2fsck' at the shell prompt. What do I do to fix it? 
·  My docking sled's top edge is not 'bent'. 
·  Why doesn't my power antenna go up and down at the right time? 
·  The upper-left corner of my screen is cut off. 
·  My config.ini file went all goofy on me, and I can't edit my favorite visuals any more! 
·  My buttons and/or knob are sticking. 
·  What does the battery icon mean? 
·  I just tried to edit one of the visuals, and now my player locks up! 
·  There are glowing red lines on my display! 
·  My display has become garbled or dim. 
·  My display is blank! 
·  Why does my Mk2 player have poor stereo separation? 
·  Why doesn't my player play very high frequencies? 
·  Why doesn't the car player put out as much bass as my CD player? 
·  How do I stop it from trying to play a bad track? 
·  My player takes a long time to boot and says it is Building Music Databases. 
·  Why does it say 'No hard disk found contact support'? 
·  Some wires have pulled out of my docking connector! 
·  My handle doesn't snap back into place as well as it used to. 
·  My handle sticks in the 'open' position. Can I fix it? 
·  There is a gap between the handle and the fascia. Can I fix it? 
·  What is the proper way to remove the display board and the main board? 
·  Why can't I use USB after installing or upgrading Emplode? 
·  Why is my Mark 1 having intermittent power failure problems? 
·  Why are there pops, clicks, screeches, and stutters when I play MP3s? 
·  Half of my display is blank! 
·  In DC mode, player responds extremly slowly to button presses, and music skips. 
·  My Mk2's volume knob is being jumpy! 
·  Why do I get an error message about reiserfs? 
·  Why did my player wake up in the car and start blasting music all by itself? 
·  Why does my player start doing things all by itself? 
·  Why do my remote and front panel buttons only work intermittently? 
·  Why won't the tuner scan for the next station? 
·  Why did the tuner change stations on me? 
·  Is there a way I can test the player's hard disk for sector errors? 
·  Why does it always say End of Playlist? 
·  Is there a master parts list for the car player? 
·  What do the ide_data_test messages mean? 
·  How do I fix the Daylight Savings Time dates on the player? 
·  There are vertical lines on my display! 


Copyright © 2001-2018 riocar.org
All logos and trademarks on this site are property of their respective owners. The comments are property of their posters.