Welcome to
 Welcome to riocar.org! Friday, August 6th 
Main Menu
· Web Links
· Downloads
· BBS/Forums
· Lens Compare
· Boot Logos
· Button Guide
· Developer Info
· Drive Upgrade
· FAQ
· Geek Guide
· Photo Gallery


  

rio car dot org FAQ (Frequently Asked Questions)



Category: Main -> Known problems and troubleshooting questions
Search the FAQ
·  Why do the visuals disappear every time I put it in the car? 
·  Why is the stereo image of my MP3 messed up? 
·  I get a 'pump' error when I try to upgrade my player firmware. 
·  I get a Windows Installer or MSI error when I install Emplode. 
·  I'm having trouble with my tuner module! 
·  My tuner gets terrible reception, but the extension cable is fine. 
·  My tuner doesn't tune in the correct frequency increments. 
·  When I pause/un-pause, or sleep/wake the player, it starts in a different part of the song. 
·  Why don't fast forward and rewind work properly? 
·  When I pull the power, sometimes it plays a different song when I start it again. 
·  I can't perform an upgrade, install a logo, or install a kernel when the player is in the docking sled. 
·  Why did my player suddenly start freezing at the boot-up logo screen? 
·  Why isn't the headlight-sense dimmer working properly? 
·  Why does my player think it's at home when it's in the car? 
·  Why doesn't my player go into standby mode when I turn off the ignition? 
·  Why is there a 'thump' from my amplifiers when I turn off the ignition? 
·  Why doesn't my Rio Car work in my Mark 2 docking sled? 
·  Why is my docking connector loose? 
·  Why is my Mark 1 getting harder and harder to pull out of the sled? 
·  Why is my Mark 2 hard to pull out of the sled? 
·  Why is my warranty seal already broken? 
·  I get a 'hardware revision check failed' message when I try to upgrade! 
·  Why did ethernet and/or USB quit working after I upgraded the software? 
·  My tuner quit working after an upgrade! 
·  Why is the song count different when I shuffle? 
·  Why can't I figure out how to do searches on the player? 
·  I selected the correct title in a search, and pressed OK, but the song did not play. Why? 
·  Why does Emplode keep getting my tags wrong? 

·  Why can't I read the display in the daylight?
 (Entry last updated on August 13th, 2003)

If your player uses the green or blue lens, you should be able to read it in daylight, assuming your dimmer (found in the Settings menu) is turned up to 100%. Check your dimmer setting first.

(Note: The dimmer is not available on the Mk1 player, its display is always at full brightness.)

If the sun shines directly on the face of the player, then you probably won't be able to read it. I can read mine in this situation, but it's very hard. In normal, ambient sunlight, though, the green and blue lenses should be adequate for general readability.

Color

The amber and red lenses will be somewhat harder to read in ambient daylight than the blue and green lenses. The problem is that the VFD (Vacuum Fluroescent Display) is greenish-blue in tint, so the green and blue lenses have the most contrast.

The lenses, in order of readability, from best to worst, are: Green, Blue, Amber, Red. Note that the red lens is only available for the Mk2 and the Rio Car.

Please click here for a chart comparing how all the colors look in different lighting conditions.

AR Coating

Early shipments of Mk2 units were mailed with lenses that were not coated with an anti-reflective (AR) coating. If you have one of these non-AR lenses, and you think that the AR coating will help you read the screen in daylight, you can contact support and they will replace the lens with an AR-coated one.

If your faceplate is non-AR, you will be able to tell because it is very shiny. If it appears to have a slight matte coating on it, then it's an AR faceplate already and there's no issue. In practice, it makes only a small difference in readability.

Faulty VFD

Some Mk2 owners have had a problem where a capacitor in the dimmer circuit has failed. This causes the display to be quite a bit dimmer than normal.

How to tell: If you are in the car at night, you should be able to turn your dimmer down all the way to 0% and still read the display. If it goes completely black when you turn it down to 0%, then you probably have a faulty display. Contact support for a repair.

If you wish to test this in more detail, here are Hugo's instructions for performing the actual test:

On the back of the display board are 3 through-hole components - with the display towards you, there are 2 caps on the left and an inductor on the right. The leg of the righthand capacitor nearest the inductor is the display anode power (this is also connected to TP1, which is labelled "60V" on the PCB just below this leg).

With the display at maximum brightness, this leg/test point should be around 60v - test against ground, ieee the case of the empeg - (i.e., in the range 57-63v). If it's any less, the display will be dimmer than it should be. Some of the displays we had back were in the range 12-25v.

WARNING! 60V is nasty voltage, it can give you a snap! Don't run your empeg with the top off unless you really know what you're doing!

The cap in question is a 100nF one which stabilises the reference voltage for the 60v PSU switcher. It's under the display, connected to pin 5 of the MAX770 chip (near the rotary control). In all the cases we've had, this one fails for some reason and as such the display PSU goes very low; there is a patch to the PCB near here for another reason on empeg (not Rio) units, which may explain why the cap has failed (too much heat when the assembler was soldering the other components on?).
Blown Motherboard Fuse

Sometimes the display might be dim because of a blown fuse on the motherboard. Please see this entry for details on how to locate and test the fuses.

Dimmer Circuit Problems

Some units have had problems with the dimmer circuit, causing the display brightness to flicker erratically when setting it. Details and repair information for this problem can be found here.


·  Why am I having problems with my car alarm or my keyless entry system? 
·  My rotary knob is slipping on its shaft! 
·  What do the synchronization errors mean? 
·  The clock on my Mark 1 player does not work. 
·  The clock on my Mark 2 player does not work. 
·  The Mark (cancel) key on the Rio remote doesn't work all the time. 
·  Why is the Shuffle menu backwards? 
·  Why does my player say 'Waiting...' on the screen? 
·  Why does my player rattle when I shake it? 
·  I don't like seeing the circuitry when the sun shines on the player. 
·  I have database errors and all of my playlists disappeared! 
·  Why does Emplode say I have less disk space than I think I should have? 
·  Why does my player sound terribly distorted when I plug it into my home stereo? 
·  My remote control quit working! 
·  I have a Kenwood head unit, and its remote is controlling both players. 
·  Why doesn't Emplode work via USB on Windows? 
·  Why doesn't emplode work via ethernet on Windows XP? 
·  Emplode freezes up on 'Checking Disk Integrity'. 
·  I got an error message about 'e2fsck' at the shell prompt. What do I do to fix it? 
·  My docking sled's top edge is not 'bent'. 
·  Why doesn't my power antenna go up and down at the right time? 
·  The upper-left corner of my screen is cut off. 
·  My config.ini file went all goofy on me, and I can't edit my favorite visuals any more! 
·  My buttons and/or knob are sticking. 
·  What does the battery icon mean? 
·  I just tried to edit one of the visuals, and now my player locks up! 
·  There are glowing red lines on my display! 
·  My display has become garbled or dim. 
·  My display is blank! 
·  Why does my Mk2 player have poor stereo separation? 
·  Why doesn't my player play very high frequencies? 
·  Why doesn't the car player put out as much bass as my CD player? 
·  How do I stop it from trying to play a bad track? 
·  My player takes a long time to boot and says it is Building Music Databases. 
·  Why does it say 'No hard disk found contact support'? 
·  Some wires have pulled out of my docking connector! 
·  My handle doesn't snap back into place as well as it used to. 
·  My handle sticks in the 'open' position. Can I fix it? 
·  There is a gap between the handle and the fascia. Can I fix it? 
·  What is the proper way to remove the display board and the main board? 
·  Why can't I use USB after installing or upgrading Emplode? 
·  Why is my Mark 1 having intermittent power failure problems? 
·  Why are there pops, clicks, screeches, and stutters when I play MP3s? 
·  Half of my display is blank! 
·  In DC mode, player responds extremly slowly to button presses, and music skips. 
·  My Mk2's volume knob is being jumpy! 
·  Why do I get an error message about reiserfs? 
·  Why did my player wake up in the car and start blasting music all by itself? 
·  Why does my player start doing things all by itself? 
·  Why do my remote and front panel buttons only work intermittently? 
·  Why won't the tuner scan for the next station? 
·  Why did the tuner change stations on me? 
·  Is there a way I can test the player's hard disk for sector errors? 
·  Why does it always say End of Playlist? 
·  Is there a master parts list for the car player? 
·  What do the ide_data_test messages mean? 
·  How do I fix the Daylight Savings Time dates on the player? 
·  There are vertical lines on my display! 


Copyright © 2001-2018 riocar.org
All logos and trademarks on this site are property of their respective owners. The comments are property of their posters.