Welcome to
 Welcome to riocar.org! Friday, August 6th 
Main Menu
· Web Links
· Downloads
· BBS/Forums
· Lens Compare
· Boot Logos
· Button Guide
· Developer Info
· Drive Upgrade
· FAQ
· Geek Guide
· Photo Gallery


  

rio car dot org FAQ (Frequently Asked Questions)



Category: Main -> Known problems and troubleshooting questions
Search the FAQ
·  Why do the visuals disappear every time I put it in the car? 
·  Why is the stereo image of my MP3 messed up? 
·  I get a 'pump' error when I try to upgrade my player firmware. 
·  I get a Windows Installer or MSI error when I install Emplode. 
·  I'm having trouble with my tuner module! 
·  My tuner gets terrible reception, but the extension cable is fine. 
·  My tuner doesn't tune in the correct frequency increments. 
·  When I pause/un-pause, or sleep/wake the player, it starts in a different part of the song. 
·  Why don't fast forward and rewind work properly? 
·  When I pull the power, sometimes it plays a different song when I start it again. 
·  I can't perform an upgrade, install a logo, or install a kernel when the player is in the docking sled. 
·  Why did my player suddenly start freezing at the boot-up logo screen? 
·  Why isn't the headlight-sense dimmer working properly? 
·  Why does my player think it's at home when it's in the car? 
·  Why doesn't my player go into standby mode when I turn off the ignition? 
·  Why is there a 'thump' from my amplifiers when I turn off the ignition? 
·  Why doesn't my Rio Car work in my Mark 2 docking sled? 
·  Why is my docking connector loose? 
·  Why is my Mark 1 getting harder and harder to pull out of the sled? 
·  Why is my Mark 2 hard to pull out of the sled? 
·  Why is my warranty seal already broken? 
·  I get a 'hardware revision check failed' message when I try to upgrade! 
·  Why did ethernet and/or USB quit working after I upgraded the software? 
·  My tuner quit working after an upgrade! 
·  Why is the song count different when I shuffle? 
·  Why can't I figure out how to do searches on the player? 
·  I selected the correct title in a search, and pressed OK, but the song did not play. Why? 
·  Why does Emplode keep getting my tags wrong? 
·  Why can't I read the display in the daylight? 
·  Why am I having problems with my car alarm or my keyless entry system? 
·  My rotary knob is slipping on its shaft! 
·  What do the synchronization errors mean? 
·  The clock on my Mark 1 player does not work. 
·  The clock on my Mark 2 player does not work. 
·  The Mark (cancel) key on the Rio remote doesn't work all the time. 
·  Why is the Shuffle menu backwards? 
·  Why does my player say 'Waiting...' on the screen? 
·  Why does my player rattle when I shake it? 
·  I don't like seeing the circuitry when the sun shines on the player. 
·  I have database errors and all of my playlists disappeared! 
·  Why does Emplode say I have less disk space than I think I should have? 
·  Why does my player sound terribly distorted when I plug it into my home stereo? 
·  My remote control quit working! 
·  I have a Kenwood head unit, and its remote is controlling both players. 
·  Why doesn't Emplode work via USB on Windows? 
·  Why doesn't emplode work via ethernet on Windows XP? 
·  Emplode freezes up on 'Checking Disk Integrity'. 
·  I got an error message about 'e2fsck' at the shell prompt. What do I do to fix it? 
·  My docking sled's top edge is not 'bent'. 
·  Why doesn't my power antenna go up and down at the right time? 
·  The upper-left corner of my screen is cut off. 
·  My config.ini file went all goofy on me, and I can't edit my favorite visuals any more! 
·  My buttons and/or knob are sticking. 
·  What does the battery icon mean? 
·  I just tried to edit one of the visuals, and now my player locks up! 
·  There are glowing red lines on my display! 
·  My display has become garbled or dim. 

·  My display is blank!
 (Entry last updated on August 10th, 2006)

If your display is completely blank, but the player can still play music and switch tracks, you might have a broken fill nipple, a blown fuse, or a frayed display board cable.

The fill nipple is the pointy glass bit on the lower right side of the display, right next to the rotary encoder. It can only be seen clearly when the faceplate assembly is removed. This is what a good display board looks like:


And this is what it looks like when the nipple is broken:


Note that the discolored area on the display that looks like a "burn mark" is actually normal and does not indicate a problem. The problem is the missing glass bulb at the lower right corner of the display.

Usually, only a violent shock to the player (such as dropping it) will cause this piece to break, either that or carelessness when working with an opened player. It's not the sort of thing that would just break on its own.

If this is what's happened to your player, the entire VFD must be replaced. Contact support to arrange for a repair.

If you want to replace the VFD glass yourself (assuming that you know what you're doing and can do delicate SMT soldering), you'll need to get around the fact that it's hard to source these Noritake VFD displays unless you're buying in bulk. Ask around the Unofficial Empeg BBS and see if anyone's got an extra for sale or can give you tips on sourcing the VFD.

WARNING:
Do not attempt to do any soldering on the player unless you have experience with soldering delicate surface-mount devices. There is a real possibility that you could permanently ruin the unit if you are clumsy, if you use too much heat, or any number of other mistakes. You're better off contacting support and having them do it for you.


If your fill nipple is still intact, but your display is blank despite being able to play music, you might have a blown fuse on the player's main board:



Contact support to help you diagnose the trouble. If you decide to troubleshoot and repair this yourself, use Michael Munsell's fuse-replacement page as your reference. Note that there is more than one fuse in that region of the motherboard that could be blown, be sure to check continuity on all of them. A blown fuse could also make the display appear dim, or garbled, rather than blank.

WARNING:
Do not attempt to do any soldering on the player unless you have experience with soldering delicate surface-mount devices. There is a real possibility that you could permanently ruin the unit if you are clumsy, if you use too much heat, or any number of other mistakes. You're better off contacting support and having them do it for you.


Also check to make sure the cable that runs between the motherboard and the display board is not frayed, as shown here:



Contact support for a repair, or if you are the D-I-Y type, solder and insulate the break:



For best results, you can get a replacement display cable from Eutronix, but keep in mind that the cable is soldered to the display board, so soldering is still needed even if you're replacing the cable.


·  Why does my Mk2 player have poor stereo separation? 
·  Why doesn't my player play very high frequencies? 
·  Why doesn't the car player put out as much bass as my CD player? 
·  How do I stop it from trying to play a bad track? 
·  My player takes a long time to boot and says it is Building Music Databases. 
·  Why does it say 'No hard disk found contact support'? 
·  Some wires have pulled out of my docking connector! 
·  My handle doesn't snap back into place as well as it used to. 
·  My handle sticks in the 'open' position. Can I fix it? 
·  There is a gap between the handle and the fascia. Can I fix it? 
·  What is the proper way to remove the display board and the main board? 
·  Why can't I use USB after installing or upgrading Emplode? 
·  Why is my Mark 1 having intermittent power failure problems? 
·  Why are there pops, clicks, screeches, and stutters when I play MP3s? 
·  Half of my display is blank! 
·  In DC mode, player responds extremly slowly to button presses, and music skips. 
·  My Mk2's volume knob is being jumpy! 
·  Why do I get an error message about reiserfs? 
·  Why did my player wake up in the car and start blasting music all by itself? 
·  Why does my player start doing things all by itself? 
·  Why do my remote and front panel buttons only work intermittently? 
·  Why won't the tuner scan for the next station? 
·  Why did the tuner change stations on me? 
·  Is there a way I can test the player's hard disk for sector errors? 
·  Why does it always say End of Playlist? 
·  Is there a master parts list for the car player? 
·  What do the ide_data_test messages mean? 
·  How do I fix the Daylight Savings Time dates on the player? 
·  There are vertical lines on my display! 


Copyright © 2001-2018 riocar.org
All logos and trademarks on this site are property of their respective owners. The comments are property of their posters.