Welcome to
 Welcome to riocar.org! Friday, August 6th 
Main Menu
· Web Links
· Downloads
· BBS/Forums
· Lens Compare
· Boot Logos
· Button Guide
· Developer Info
· Drive Upgrade
· FAQ
· Geek Guide
· Photo Gallery


  

rio car dot org FAQ (Frequently Asked Questions)



Category: Main -> Known problems and troubleshooting questions
Search the FAQ
·  Why do the visuals disappear every time I put it in the car? 
·  Why is the stereo image of my MP3 messed up? 
·  I get a 'pump' error when I try to upgrade my player firmware. 
·  I get a Windows Installer or MSI error when I install Emplode. 
·  I'm having trouble with my tuner module! 
·  My tuner gets terrible reception, but the extension cable is fine. 
·  My tuner doesn't tune in the correct frequency increments. 
·  When I pause/un-pause, or sleep/wake the player, it starts in a different part of the song. 
·  Why don't fast forward and rewind work properly? 
·  When I pull the power, sometimes it plays a different song when I start it again. 
·  I can't perform an upgrade, install a logo, or install a kernel when the player is in the docking sled. 
·  Why did my player suddenly start freezing at the boot-up logo screen? 
·  Why isn't the headlight-sense dimmer working properly? 
·  Why does my player think it's at home when it's in the car? 
·  Why doesn't my player go into standby mode when I turn off the ignition? 
·  Why is there a 'thump' from my amplifiers when I turn off the ignition? 
·  Why doesn't my Rio Car work in my Mark 2 docking sled? 
·  Why is my docking connector loose? 
·  Why is my Mark 1 getting harder and harder to pull out of the sled? 
·  Why is my Mark 2 hard to pull out of the sled? 
·  Why is my warranty seal already broken? 
·  I get a 'hardware revision check failed' message when I try to upgrade! 
·  Why did ethernet and/or USB quit working after I upgraded the software? 
·  My tuner quit working after an upgrade! 
·  Why is the song count different when I shuffle? 
·  Why can't I figure out how to do searches on the player? 
·  I selected the correct title in a search, and pressed OK, but the song did not play. Why? 
·  Why does Emplode keep getting my tags wrong? 
·  Why can't I read the display in the daylight? 
·  Why am I having problems with my car alarm or my keyless entry system? 
·  My rotary knob is slipping on its shaft! 
·  What do the synchronization errors mean? 
·  The clock on my Mark 1 player does not work. 
·  The clock on my Mark 2 player does not work. 
·  The Mark (cancel) key on the Rio remote doesn't work all the time. 
·  Why is the Shuffle menu backwards? 
·  Why does my player say 'Waiting...' on the screen? 
·  Why does my player rattle when I shake it? 
·  I don't like seeing the circuitry when the sun shines on the player. 
·  I have database errors and all of my playlists disappeared! 
·  Why does Emplode say I have less disk space than I think I should have? 
·  Why does my player sound terribly distorted when I plug it into my home stereo? 
·  My remote control quit working! 
·  I have a Kenwood head unit, and its remote is controlling both players. 
·  Why doesn't Emplode work via USB on Windows? 
·  Why doesn't emplode work via ethernet on Windows XP? 
·  Emplode freezes up on 'Checking Disk Integrity'. 
·  I got an error message about 'e2fsck' at the shell prompt. What do I do to fix it? 
·  My docking sled's top edge is not 'bent'. 
·  Why doesn't my power antenna go up and down at the right time? 
·  The upper-left corner of my screen is cut off. 
·  My config.ini file went all goofy on me, and I can't edit my favorite visuals any more! 
·  My buttons and/or knob are sticking. 
·  What does the battery icon mean? 
·  I just tried to edit one of the visuals, and now my player locks up! 
·  There are glowing red lines on my display! 
·  My display has become garbled or dim. 
·  My display is blank! 
·  Why does my Mk2 player have poor stereo separation? 
·  Why doesn't my player play very high frequencies? 
·  Why doesn't the car player put out as much bass as my CD player? 
·  How do I stop it from trying to play a bad track? 
·  My player takes a long time to boot and says it is Building Music Databases. 
·  Why does it say 'No hard disk found contact support'? 
·  Some wires have pulled out of my docking connector! 
·  My handle doesn't snap back into place as well as it used to. 
·  My handle sticks in the 'open' position. Can I fix it? 
·  There is a gap between the handle and the fascia. Can I fix it? 

·  What is the proper way to remove the display board and the main board?
 (Entry last updated on May 28th, 2002)

The display board and the main board should generally be left alone and not removed. They are fragile and you might not be able to get replacements for them easily.

There are some rare situations when you might want to remove the display board. For example, if you want to do Brian Mihulka's Backlit Button Hack. And the main board might need to be removed if you are performing a repair on the board such as replacing the home/AC power connector yourself, or repairing broken circuit traces caused by stress on the home RCA plugs.

If you do this, there is one absolutely critical thing to remember: Make absolutely sure that the ribbon cable to the display gets plugged back in exactly right. It is very easy to get it "off by one pin", causing it to blow fuses on the main board, causing this problem. Same with the IDE cable, the unit will appear to just "not boot" if the IDE cable is off by one. Since the two connector/cable assemblies interfere with each other a bit, you might think that one or the other is plugged in wrong even when they are plugged in right. Look closely at the pins and the connectors and make super-sure that all of the pins are properly going into all of the holes on the connector.

Also, while you are working on this, make sure not to damage the capacitors on the back of the display board, they can be broken off accidentally. Also watch the fill nipple on the VFD display.

Movie files of the procedures for removing these components:

Removing Display (2.72mb mpeg). Not shown: Removing the disk drive tray and removing the screws on the sides of the casing to free the display board.

Removing Mainboard (6.21mb mpeg).

Replacing Display (5.69mb mpeg).

By the way, when working with the display, if you mess with the hex standoff bolts that hold the fascia to the display board, make sure not to over-torque them. Otherwise, this might happen:


·  Why can't I use USB after installing or upgrading Emplode? 
·  Why is my Mark 1 having intermittent power failure problems? 
·  Why are there pops, clicks, screeches, and stutters when I play MP3s? 
·  Half of my display is blank! 
·  In DC mode, player responds extremly slowly to button presses, and music skips. 
·  My Mk2's volume knob is being jumpy! 
·  Why do I get an error message about reiserfs? 
·  Why did my player wake up in the car and start blasting music all by itself? 
·  Why does my player start doing things all by itself? 
·  Why do my remote and front panel buttons only work intermittently? 
·  Why won't the tuner scan for the next station? 
·  Why did the tuner change stations on me? 
·  Is there a way I can test the player's hard disk for sector errors? 
·  Why does it always say End of Playlist? 
·  Is there a master parts list for the car player? 
·  What do the ide_data_test messages mean? 
·  How do I fix the Daylight Savings Time dates on the player? 
·  There are vertical lines on my display! 


Copyright © 2001-2018 riocar.org
All logos and trademarks on this site are property of their respective owners. The comments are property of their posters.